Photo Bundle



Requirements

We thoroughly test and support this product on the systems listed below. This product may also work in other configurations, but we do not guarantee it.

Host Requirements

Blow Up and Bokeh are plug-ins and require a host application. Exposure and Snap Art work as standalone applications and plug-ins. They will all work with the hosts listed below.

  • Adobe Photoshop CS6 or newer
  • Adobe Photoshop Elements 12 or newer
  • Adobe Photoshop Lightroom 4 or newer

Additionally, Exposure 5 and Snap Art 4 work with Apple Aperture 3 or later.

System Requirements

  • Apple Mac users need OS X Mountain Lion (10.8) or later
  • Microsoft Windows users need Windows 7 or later
  • An Intel Core 2 processor or compatible
  • A monitor with 1280x768 resolution or greater